Rubyでrmagick導入時の「Can’t find the ImageMagick library or one of the dependent libraries.」対策

良く忘れるので備忘を兼ねて投稿します。Railsで開発中にRmagickを使おうとしたところ、以下エラーでインストールが出来ませんでした。原因は必要なライブラリがインストールされていない為です。

エラー内容

ERROR: Can't install RMagick 4.2.4.
Can't find the ImageMagick library or one of the dependent libraries.
Check the mkmf.log file for more detailed information.

対策

単純に必要なライブラリを導入した後、再度gem installするだけです。

apt install libgraphicsmagick1-dev graphicsmagick-libmagick-dev-compat libmagickcore-6.q16-dev
gem install rmagick

タグ . ブックマークする パーマリンク.

コメントを残す

メールアドレスが公開されることはありません。

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください